Node.js devs, imagine npm doesn’t exist. Instead, if you’re nice, you make a list of your dependencies in your README and everyone installs them manually. (Seriously.) Also, you can list names any way you like. So, if a library is called libclutter-1.0-dev, list it as clutter, libclutter, clutter-1.0, … and people will magically know you meant libclutter-1.0-dev (or, more likely, they’ll do an, e.g., apt search clutter to try and find out wtf you meant). Welcome to C/Vala development in 2021.

🤷‍♂️

(Oh, and every library you install is essentially a global install that is shared with every project you’re trying to build. So basically everything is ~ an npm install --global.)

This is really something an operating system like elementary OS has to tackle for its apps at least if it wants to attract developers (even if, say, the GNOME, etc., folks are happy with the status quo and/or enjoy the right of passage it represents for keeping out the hoi polloi).

@aral That reminds me of two months ago when i tried to make a local build of Geary to maybe do some visual tweaks. I just couldn't get it to work because of dependency hell / version mismatching, gave up after two days.

@ff0000 I’ve got a better one for you: I got Geary to build and added Fastmail to the list of accounts you could set up easily alongside the surveillance-based Gmail, etc. Pull request was denied. Still legitimises/encourages people to use Gmail to this day. (So maybe you dodged a bullet?)

@aral @ff0000 What was the reason for denial of that pull request? Surely it cant be that they only want to support gmail?

Follow

@aral @aramloosman ooof a lot of words just to say: neh, just make so that *insert small ethical company*'s integration is just as easy as multi billion company with endless money Google.

· · Web · 0 · 0 · 1
Sign in to participate in the conversation
chaos.social

chaos.social – a Fediverse instance for & by the Chaos community