Follow

Habe eine Jitsi Server per Docker eingerichtet. Nun funktioniert das ***** Zertifikat aber nicht. Hier haben doch einige so einen Sever eingerichtet. Hat jemensch 5 min Zeit darüber zu quatschen? Ist wahrscheinlich nur ein doofer Fehler - hänge aber ewig dran

fsmedtech.medizin.uni-tuebinge

Das wäre die relevante config

HTTP_PORT=80
HTTPS_PORT=443

PUBLIC_URL="fsmedtech.medizin.uni-tuebinge"

=192.168.1.1

# Enable Let's Encrypt certificate generation.
ENABLE_LETSENCRYPT=1

LETSENCRYPT_DOMAIN=fsmedtech.medizin.uni-tuebingen.de

LETSENCRYPT_EMAIL=jitsi@hyteck.de

Show thread

@heimdall
Das Zertifikat ist auf die falsche Domain ausgestellt , wie installierst Du das Zertifikat ?

@jhummel Das sollte der Dockercontainer selber machen, laut readme github.com/jitsi/docker-jitsi-
Meine config habe ich dem ersten post angehängt.

@heimdall die Config passt aber das muss doch noch ein Install ausgeführt werden das Zert kommt ja nicht so in den Docker
Hast Du das schon mal ausgeführt : usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh siehe hier
github.com/jitsi/docker-jitsi-

@heimdall

Hast Du auf ein .env File angelegt , also nicht das example editiert?

The configuration is performed via environment variables contained in a .env file. You can copy the provided env.example file as a reference.

@x2ero Ich sag auf jeden Fall Bescheid wenn ich rausfinde was es ist..

@heimdall In meinem Fall vermute ich dass der Reverse Proxy falsch konfiguriert ist. ich habe mein zertifikat für den davor geschalteten apache gemacht.

@x2ero Was bei mir so komisch ist, ist dass http:// gar nicht geht. Eigentlich sollte es zur https:// seite weiterleiten dachte ich

@heimdall ja... das auch ,-)
Ich habe es mittlerweile mit einem vorgefertigeten image auf einem v-server versucht, da ging das auch nicht so recht, jetzt installiere ich es von hand. Toi Toi Toi

@x2ero Drücke die Daumen. Ich habe nicht genug Ahnung für eine manuelle installation

@heimdall Das hat jetzt geklappt, aber die Zertifikats Frage ist in der Tat auch hier kinffelig. Muss man von Hand machen.

@heimdall
Ich habe das hier gemacht.
jitsi.org/downloads/

Funktioniert...
Wenn man die zertifikate manuell einsetzt.

@heimdall Mit nginx hab ich irgendwo hier ne kleine Anleitung, wegen des Zertifikates. Der certbot hat bei mir nicht funktioniert.
@heimdall Finde es gerade nicht, aber nach der Installation waren es nur folgende Kommandos:
systemctl stop nginx
certbot-auto certonly --standalone -d domain.tld
Danach musst Du in der Datei /etc/nginx/sites-available/domain.tld.conf die Zertifikate austauschen durch die von letsencrypt. Dann noch ein beherztes
systemctl start nginx
Und schon geht alles. Ich wollte noch einen Bug filen bei Jitsi, bin aber gerade etwas überlastet...
@heimdall Sag bitte Bescheid, ob das bei Dir so funktioniert hat, oder ob ich irgendwas vergessen hab.
Sign in to participate in the conversation
chaos.social

chaos.social – a Fediverse instance for & by the Chaos community