Follow

Huch? Einige der LXC-Container (Debian 10) in meinem Proxmox, verlieren regelmaeßig die IP-Adressen. Auch wenn ich die statisch setze. Ideen? :boost_ok:

@n0emis Ich hatte mal ne Weile bei ein paar meiner Kisten das Problem, dass sie zwar in der interfaces statisch konfiguriertes v6 hatten, aber nach einiger Zeit dieses nicht mehr ging. Es sah damals so aus, als hätte man trotz statischem v6 auf RAs reagiert und sich eine default Route gesetzt. Als man dann merkte, dass man ja statisches v6 macht, wollte man das statisch konfigurieren, konnte aber die Route nicht neu setzen. Und dann ist irgendwann die RA-Route ausgelaufen... Bumm, v6 weg.

@n0emis Momentan ist mein Fix, dass ich zusätzlich im post-up eine Route mit Metrik 1023 erstelle. Diese Metrik kriegst du i.A. durch automatische Tools für eine Route nicht zugewiesen.

@n0emis
Ist da vielleicht noch ein dhcpcd unterwegs? /etc/network/interfaces vs. systemd-networkd oder so?

@n0emis
Hm. Ich hatte das Problem halt immer wenn ich mit systemd-networkd die IP fest konfiguriert habe und gleichzeitig in /etc/network/interfaces noch was drin stand. Aber das scheint ja bei dir nicht der Fall zu sein.

@tsia Genau. Das passiert ja auch, wenn die Container die Adresse per DHCP ziehen. Aber ich habe an anderer stelle gehoert, dass die Debian10-Container wohl probleme machen wuerden. Ich werde das dann wohl mal mit einen Ubuntu-Container versuchen...

@n0emis
Das spannende ist, hier ist auch alles voll mit Debian 10 Containern und ich hab damit gar keine Probleme.

Sign in to participate in the conversation
chaos.social

chaos.social – a Fediverse instance for & by the Chaos community